nix-config/modules/home/shell/macchina.nix
2024-09-29 00:51:15 -04:00

99 lines
3.5 KiB
Nix
Raw Permalink Blame History

This file contains invisible Unicode characters

This file contains invisible Unicode characters that are indistinguishable to humans but may be processed differently by a computer. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

{pkgs, ...}:
with pkgs; {
programs.macchina = {
enable = true;
config = {
theme = "Mezora";
interface = "wlp4s0";
show = [
"Distribution"
"Kernel"
"LocalIP"
"DesktopEnvironment"
"WindowManager"
"Packages"
"Resolution"
"Terminal"
"Shell"
"Uptime"
"ProcessorLoad"
"Memory"
];
};
themes = {
Mezora = {
custom_ascii =
# I prefer to use the default icon on macOS
if stdenv.isDarwin
then {}
else {
path = writeText "nix_logo" ''
 
 
 
 
 
 
 
 
 
 
 
 
 
 
'';
};
separator = "";
separator_color = "blue";
key_color = "blue";
palette = {
type = "Dark";
visible = true;
glyph = " ";
};
box = {
border = "rounded";
visible = true;
inner_margin = {
x = 1;
y = 1;
};
};
bar = {
glyph = "";
hide_delimiters = true;
visible = true;
};
keys = {
kernel = " Kernel";
packages = " Packages";
cpu_load = " CPU";
memory = " Memory";
resolution = "󰔂 Res";
uptime = " Uptime";
distro = " Distro";
machine = "󰌢 Machine";
de = " DE";
local_ip = "󰤨 Local IP";
terminal = " Terminal";
shell = " Shell";
};
};
};
};
}